Virtual Pascal

Classic Object Pascal for free

G'day Folks,

Is anyone else experiencing issues with compiling, debugging  etc

under W10?.. (Both x32 & 64 are giving me ..heartburn)!

Or, more to the point, does anyone have a foolproof solution....

.....hope, hope!  :-)

I have tried elevating it to run as admin etc .. but during a debuigging

session, it still dies sooner or later with what I think is related to

the W10 (rigorous) permissions ...   NB: I don't get a specific error.

NB: I have tried flagging vp.exe as 'admin' as well & I've also tried

setting it to run in compatibility with XP-sp/3.  (And it certainly used to

work on that).

At the moment, I'm 'forced' to reboot into XP to make any progress

(NB: I know about VMs... ... just .. not interested in running that way).

FWIW It used to work fine on W7-Ult .. but since upgrading to W10pro

I can't get very far...

Any ideas pls?

Many Thanks.


Views: 175

Reply to This

Replies to This Discussion

Some things to try (no different than Win8 though)

- install outside program files.

- install on a non system drive (e.g. a subst). The root of a system drive is not writable. The root of a non system drive is also non writable, but that can be turned off.

- disable smartscreen, windows defender and other security software. If this solves the problems, you can add acceptions

> NB: I don't get a specific error.

And there is nothing in the Windows event logs?

FWIW, I've turned off M$ offers of a free upgrade to WX (If it ain't broke don't fix it...) and given what I've read about everything that W X is doing under the covers, sending info to the NSA^H^H^HRedmond under the guise of "Customer Experience Programs", I'm not likely to ever upgrade other than to a variety of Linux, and I think that by the time W7 support ends in 2020, Linux will be good enough.

Thanks Robert...

I think it all boiled down to the fact I had forgotten I was running under

W10-x64 (vs x32).... Tho' why the Winsxs doesn't handle it, is a

bit of a surprise . (The Winsxs seems to work quite well on other

x32 things).

As a side issue, once I found that out, I did try running an XP-compiled

version of my program under W10x64 ... but it didn't like that either.

Even tho' it was via an elevated cmd prompt.

I've reloaded a different partition with W10x32p (& W8.1p-x32 as well) -

...and all seems fine now, thankfully.

As regards the comments about Win10...

Yes it does seem v-e-r-y close to W8.1 and AFAIK, it just seems to be MS's

method of getting in (late) to the 'mobile' market - currently 'owned' by Apple

& Google.  ie: They're so late 'catching on', I think thay had no choice but to

make W10 free!  (...Well, free for 1 year).

Not surprisingly - they've again moved familiar stuff around, so that you have to

hunt to find out where they've put it.   Tho' when you get there, it's 99% like the

version you're used-to <sigh>.

Even tho' you may not want to use W10 now, I'd recommend getting the ISO

sometime before the free period expires... tho' it's true, there has already

been a major update for it - which was stuffed - & had to be reissued a couple

of days later!    And yes, I was one of the ones who 'got caught' in the...

endless reboot ...!   :-) :-(




© 2022   Created by Allan Mertner.   Powered by

Report an Issue  |  Terms of Service